Channable tool degraded performance
Incident Report for Channable
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 15:32 CEST
Investigating
We are currently investigating an issue that is causing the Channable tool on app.channable.com to perform slower than usual.
While this incident is ongoing the Channable tool might be slow or unavailable.
Posted Oct 16, 2024 - 15:19 CEST
This incident affected: Channable tool.