Certain Google Ads feature are not working as expected

Incident Report for Channable

Resolved

We have found a working solution to the problem and we have resumed normal operations. All features are working as expected again.
Posted Mar 31, 2025 - 16:47 CEST

Update

We are continuing to approach this problem with new solutions. A possible fix is being currently verified.
Posted Mar 31, 2025 - 16:33 CEST

Identified

We are seeing an increased number of failed exports for Google Ads. We are working to resolve this issue as we know what is causing this.
Posted Mar 31, 2025 - 15:27 CEST
This incident affected: Ads and Insights & Analytics.