Our call provider is currently having trouble
Resolved
Aircall reported the issue to have been resolved completely.
Posted Apr 16, 2025 - 21:44 CEST
Update
Support agents report certain calls are coming through again. We hope to be back to full available as soon as possible.
Posted Apr 16, 2025 - 16:57 CEST
Monitoring
We'll be monitoring the status page from Aircall, while we wait for them to implement a fix.
Posted Apr 16, 2025 - 16:24 CEST
Investigating
Our Support department is currently not available over the phone, because our call provider is experiencing issues.
They have already posted their own status page as well: https://status.aircall.io/incidents/tvtssv8x3r9s
We'll be monitoring the situation.
Posted Apr 16, 2025 - 16:23 CEST
This incident affected: Support (Phones).